当前位置: 首页 > OpenSource > 正文

Your intltool is too old. You need intltool 0.35.0 or later

编译rrdtool时,提示这样的错误:
checking for intltool >= 0.35.0… 0.31.2 found
configure: error: Your intltool is too old.  You need intltool 0.35.0 or later.

解决办法如下:
wget http://ftp.gnome.org/pub/gnome/sources/intltool/0.40/intltool-0.40.6.tar.gz
tar zxvf intltool-0.40.6.tar.gz
cd intltool-0.40.6
./configure
make && make install

编译之后有个地方比较搞笑,原来作者也挺有幽默感的哦!
SOLARIS HINT: if you want to build the Perl module for the native Perl (the one shipping with Solaris) you will need the Sun Forte compiler installed on your box or you have to hand-tune bindings/perl-shared/Makefile while building!

Now go to $INSTALL_DIR/share/rrdtool/examples/ and run them to see if your build has been successful.

checking in… and out again
ordering CD from http://tobi.oetiker.ch/wish …. just kidding 😉
Config is DONE!

          With MMAP IO: yes
      Build rrd_getopt: no
       Static programs: no
          Perl Modules: perl_piped perl_shared
           Perl Binary: /usr/bin/perl
          Perl Version: 5.8.5
          Perl Options: PREFIX=$(DESTDIR)/usr/local/rrdtool-1.3.8 LIB=$(DESTDIR)/usr/local/rrdtool-1.3.8/lib/perl/5.8.5
          Ruby Modules:
           Ruby Binary: no
          Ruby Options: sitedir=$(DESTDIR)/usr/local/rrdtool-1.3.8/lib/ruby
    Build Tcl Bindings: no
 Build Python Bindings: yes
          Build rrdcgi: yes
       Build librrd MT: yes
     Link with libintl: yes

             Libraries: -lxml2 -lcairo -lcairo -lcairo -lm  -lcairo -lfreetype -lz -lfontconfig -lpng12 -lpixman-1   -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lfreetype -lz -lfontconfig -lpng12 -lpixman-1 

Type ‘make’ to compile the software and use ‘make install’ to
install everything to: /usr/local/rrdtool-1.3.8.

       … that wishlist is NO JOKE. If you find RRDtool useful
make me happy. Go to http://tobi.oetiker.ch/wish and
place an order.

本文固定链接: http://2hei.net/your_intltool_is_too_old_you_n.html | 2hei's site

该日志由 2hei 于2009年08月05日发表在 OpenSource 分类下,
原创文章转载请注明: Your intltool is too old. You need intltool 0.35.0 or later | 2hei's site
关键字:

报歉!评论已关闭.